Robot Cell Simulator – Referenz der Befehls-API
« Befehls-API | Inhalt | Ablauf, Prozessor und Genauigkeit »
MenüaktionenBedienfeld und FensterFenster der Wettläufe (race_study)Einstellungen (Einstellungen > Konfigurieren...)

Alles Folgende kann über die UI-Befehle der Befehls-API gelesen und geändert werden, ohne Bildschirmfotos. Die Liste wurde von der API selbst erzeugt (ui_actions, ui_list mit hidden) und entspricht daher dem Programm. Ein Element wird über seine id aus ui_list oder über seine Beschriftung (+ path, type, window) angegeben; die Beschriftungen sind die der deutschen Oberfläche (englische Oberfläche: English). Listen von Robotern, Programmen und Punkten hängen von der geladenen Zelle ab und werden mit ui_view gelesen.

Die Optionen der Registerkarte Simulation lassen sich auch ohne die UI-Befehle setzen: set, run (auch up), fast_run, sim_options, sim_action, live_check, zones (mode), view, robot, collision_ignore, collision_report, race_rules, race_study (unten), report_open, model_converter, model_cache (unten) und robust_test – siehe Befehle. Ohne die Zusatzlizenz API / CLI gehen nur lesende Befehle.

Die WARTE ZEIT-Befehle der Roboterprogramme, die im Fenster nur als Warnungen in der Konsole und im Bericht (Abschnitt 3. Was zu prüfen ist) erscheinen, liest wait_times (optional robot = Teil des Roboternamens; Antwort waitTimes [{robot, program, point, command, seconds, condition, line}], count, secondsTotal, note) – nur lesend, ohne die Lizenz API / CLI, auch während der Simulation; status liefert ihre Anzahl (waitTimes), die Laufdatei *.rcsrun.json enthält das Array waitTimes.

Die Kamera der 3D-Ansicht (Mausrad, Verschieben) stellt view ein: zoom (Faktor 0.01..100, > 1 näher) und target ([x, y, z] mm, die Mitte der Ansicht); jede Antwort von view enthält camera {target, scale, distance} nach allen Änderungen des Befehls (target [mm] die Mitte der Ansicht, scale die Höhe der Ansicht im Ziel [mm], distance = scale / (2·tan 22,5°) der Abstand der Kamera in der Perspektive, Sichtwinkel 45°). In einem Befehl wird zuerst standardView angewendet, dann fitAll / viewAll, dann target und zoom: {"cmd":"view","standardView":"default","target":[x, y, z],"zoom":6} behält das Ziel. Die 3D-Ansicht selbst ist das Element view3d von ui_list: ui_context mit ihrer id öffnet das Kontextmenü der Ansicht, ui_key sendet die Tasten der Ansicht (Bedienfeld und Fenster). status liefert fps (gezeichnete Bilder der Ansicht pro Sekunde, Zeichnen auf Anforderung) und viewSyncMs (mittlere Zeit des GUI-Threads pro Bild für die Übernahme der Szenenänderungen, ms), beide -1 in der Variante mit dem JT-Leser; seit 2026-10-25 außerdem glRenderer (Grafikkarte der Ansicht: Renderer / Hersteller / OpenGL-Version, wie in der Konsolenzeile 3D view: graphics card ...) und paintFps (Zeichnungen der Widgets der 3D-Ansicht pro Sekunde seit dem vorigen status, auch in der Variante mit dem JT-Leser; in der Qt3D-Variante gilt fps); seit 26.10.2026 außerdem das Objekt memory (privateMB, workingSetMB, peakWorkingSetMB, peakPagefileMB) und der Diagnosebefehl memory_trim. Die Antwort von robot enthält flange ([x, y, z] mm, die Position des Flansches des Roboters in der Szene) – Zoom auf ein Roboterwerkzeug: {"cmd":"view","target":[x, y, z],"zoom":6} mit den Werten aus flange, danach scene_shot; toolKind (cad / dummy / none) und toolText sagen, ob der Roboter das CAD-Modell seines realen Werkzeugs oder ein Dummy-Werkzeug hat (eine Näherung in den Arbeitsbereichen und der 3D-Kollisionsprüfung; ein Roboter mit 3D-Modell seines Werkzeugs hat kein Dummy-Werkzeug). Die am Roboter angebauten Elemente: tool_info, tool_remove, tool_hide / tool_show (Robotermenü Montierte Elemente und Doppelte Modelle entfernen). Mit view collisionPlaces true sind die Kollisionsstellen des letzten Laufs Kugeln in der Szene (rot = 3D-Berührung, gelb = 3D-Annäherung ohne Kontakt, violett = Gefahr aus den Arbeitsbereichen; Farben: view collisionPlaceColor3D / collisionPlaceColorZone / collisionPlaceColorProximity); die Antwort von collision_case action "points" enthält point ([x, y, z] mm, die Kugel des gezeigten Kontakts) – {"cmd":"view","target":point,"zoom":6} vor scene_shot zeigt die Stelle mit beiden Robotern in ihren Achsen bei diesem Kontakt. Ein 3D-Fall behält bis zu 4 Kontaktstellen, die mehr als 400 mm auseinander liegen, und eine Zeile kann mehrere Fälle zusammenfassen – jede Stelle hat ihre eigene Kugel, Zeit und Roboterachsen (es kann also mehr Kugeln als Zeilen geben): der erste Aufruf zeigt die erste Stelle der Zeile, jeder wiederholte Aufruf mit demselben Schlüssel die nächste (nach der letzten wieder die erste); der Schlüssel eines einzelnen Kontakts zeigt genau diesen Kontakt. Die Antwort enthält auch place / places (3D-Zeilen) und shown (was die 3D-Ansicht zeigt). Bei einer Zeile der Arbeitsbereiche fahren die Roboter in die Programmpunkte, und die 3D-Modelle werden in dieser Stellung einmal geprüft: Berührung = orange Kugel (3D-Kontakt in den Programmpunkten) und Warnung in der Konsole, sonst der kleinste Abstand – dieses Ergebnis kommt etwa 0,2–6 s später in der Konsole. collisionPlaceLabels false blendet die Texte über den Kugeln aus.

Die Gruppe Kartesisch (TCP) der Registerkarte Roboterachsen (Kartesisches Verfahren) hat den Befehl robot als Gegenstück: tcp {tool, base} liest die TCP-Position im gewählten Werkzeug und in der gewählten Basis (Antwort tcp und tcpScene), moveTcp {x, y, z, [a, b, c], tool, base, frame} fährt den TCP dorthin mit derselben inversen Kinematik wie die Schaltflächen − / + (S / T der aktuellen Position); mit frame "scene" wird das Ziel in der Szene angegeben, z. B. tcpScene oder flange eines anderen Roboters. Das Kontextmenü des Roboters Alle Programme suchen (Find all programs, Model Browser) ist rebuildPrograms true: der Programmbaum wird neu aufgebaut, neue oder geänderte Folge- / UP-Dateien des Archivs werden gelesen. Die Antwort von robot enthält auch base (den Roboterfuß in der Szene).

Ein Bild nur der 3D-Szene (OpenGL, mit Beschriftungen und Dekorationen, wie das Szenenbild in den Berichten) schreibt scene_shot {"cmd":"scene_shot","file":"C:/temp/cell.png"} (Antwort file, bytes) – nur lesend, ohne die Lizenz API / CLI, wie ui_shot für Fenster und Elemente.

Menüaktionen

{"cmd":"ui_click","action":"Datei > Datei öffnen"}; Aktionen mit Zustand (Häkchen) auch ui_set true / false.

Ohne Dialoge: Datei > Datei öffnen ist auch der Befehl open (Pfade des Assistenten als systemRoot / robotArchives), Datei > Roboter an Studienpositionen einfügen der Befehl insert_study_robots. Die Titelleiste des Fensters zeigt den vollen Pfad der geöffneten Simulationsdatei und der Zelle / Studie ({"cmd":"ui_windows"}, Feld title).

MenüpfadZustand
Datei > Datei öffnenohne Dialoge: open
Datei > AssistentPfade: systemRoot / robotArchives von open
Datei > Sitzung öffnen...
Datei > Sitzung speichern...
Datei > Simulationspaket öffnen...Dateidialog (ui_file), dann wie Simulation laden; das Paket wird mit dem Fortschrittsfenster Simulationspaket öffnen entpackt (Simulationspaket ... wird entpackt: n von m Datei(en), Abbrechen; Status: extracting); ohne Dialoge: package_open (file, convert)
Datei > Simulationspaket speichern (*.rcsz)...Dateidialog (ui_file), Fenster: Roboterdaten aufnehmen (Programme, Konfiguration, Maschinendaten, Langtexte) (ein), Original-Modelldateien als Quelle einschließen (ein) mit der geschätzten Größe der Paketteile (API dryRun: estimatedSize {glb, source, robots, total} in MB), Speichern / Abbrechen; das Paket ist eigenständig, die Studiendatei wird nie aufgenommen; ohne Dialoge: package_save (file, includeRobotData, includeSource, dryRun)
Datei > Zuletzt geöffnete Dateien > Dateinameein Eintrag je zuletzt geöffneter Datei
Datei > Zuletzt geöffnete Dateien > Leeren
Datei > Datei einfügen...
Datei > Roboter an Studienpositionen einfügen...ohne Dialoge: insert_study_robots
Datei > Roboter aus Archiv einfügen...
Datei > Neue Szene
Datei > Szene schließen
Datei > Beenden
Navigation > Alles einpassen
Navigation > Alle einblenden
Navigation > Zoomenui_set true / false
Navigation > Verschiebenui_set true / false
Navigation > Drehenui_set true / false
Navigation > Normansicht > Standard
Navigation > Normansicht > Oben
Navigation > Normansicht > Unten
Navigation > Normansicht > Links
Navigation > Normansicht > Rechts
Navigation > Normansicht > Vorne
Navigation > Normansicht > Hinten
Auswahl > Ausblenden
Auswahl > Einblenden
Auswahl > Nur diese einblenden
Auswahl > Einblendung umkehren
Ansicht > Achsen anzeigenui_set true / false
Ansicht > Perspektivmodusui_set true / false
Ansicht > Screenshot
Ansicht > Aufgezeichnete Roboterbahn anzeigenui_set true / false
Ansicht > Roboterbeschriftung anzeigenui_set true / false
Ansicht > Nullpunkt anzeigenui_set true / false
Ansicht > Raster anzeigenui_set true / false
Ansicht > Konsolen und Lineareinheiten anzeigenui_set true / false
Ansicht > Werkzeug-TCP während der Simulation anzeigenui_set true / false; Befehl view simulationTcp (nur das TCP-Koordinatensystem des Werkzeugs, aus den Achswerten des gezeichneten Modells; seit 2026-10-25 kein Koordinatensystem des Programmpunkts / Ziels)
Ansicht > Kollisionsstellen anzeigenui_set true / false; Befehl view collisionPlaces (Kugeln: rot = Berührung Live 3D, violett = Kollisionsgefahr aus den Arbeitsbereichen; bis zum nächsten Lauf)
Ansicht > Beschriftung der Kollisionsorte anzeigenui_set true / false; Befehl view collisionPlaceLabels (Texte über den Kugeln: Art, Roboter, Zeit; auch im Kontextmenü der 3D-Ansicht)
Ansicht > Farben der Kollisionsstellen...Dialog (ui_windows / ui_click); Befehl view collisionPlaceColor3D, collisionPlaceColorZone, collisionPlaceColorProximity ("#rrggbb", Standard #ff0000 / #e000e0 / #ffc000)
Ansicht > Größe der Signalbeschriftungen...Fenster mit Schieberegler 30..300 %; Befehl view signalLabelSize
Fenster > Symbolleiste ein-/ausblendenui_set true / false
Fenster > Bedienfeld ein-/ausblendenui_set true / false
Fenster > Meldungsfenster ein-/ausblendenui_set true / false
Fenster > Attributfenster ein-/ausblendenui_set true / false
Simulation > Simulation speichern...
Simulation > Simulation laden...
Simulation > Zuletzt geladene Simulationen > Dateinameein Eintrag je zuletzt geladener Simulationsdatei (neueste zuerst, bis 15); lädt sie ohne Dateidialog; Liste: recent_files, Laden: load file
Simulation > AGENTS.md automatisch aktualisierenui_set true / false [aus]; Einstellung AgentsMd_Auto; Befehl agents_md auto true / false (status: agentsMdAuto); siehe AGENTS.md
Simulation > AGENTS.md jetzt aktualisierenSymbol Neu laden; funktioniert auch bei ausgeschalteter Option und während eines Laufs (leichte Aktualisierung); ui_click; Befehl agents_md update true (get true liest die Datei, notes "Text" ersetzt den NOTES-Block, file "Pfad" schreibt eine Kopie)
Extras > Basen gegen die Studie prüfen...Fenster: Toleranz Position / Drehung, Berichtsfelder Projekt, Ort, Kunde, Team, Station, Kommentar, Bericht mit der aktuellen 3D-Ansicht; ohne Dialoge: base_check (tolMm, tolDeg, project, place, customer, team, station, comment, report, view)
Extras > Basen gegen die Studie prüfen... > Fenster Berechnete RoboterpositionenTabelle mit den Kontrollkästchen der Roboter, Studie überschreiben (Sicherungskopie .bak) statt einer Kopie <Studie>_calibrated.xml (Standard aus), Simulation mit den neuen Roboterpositionen neu laden (Standard an), Schaltfläche Auf die gewählten Roboter anwenden; ohne Dialoge: base_check (apply = true, robots, saveStudy, overwrite, reload; Ergebnis calibration, apply)
Extras > Schweißpunktbericht...Fenster: Toleranz Position (Standard 2 mm), Toleranz Zangenachse (Standard 5°), Bericht mit der aktuellen 3D-Ansicht, Koordinatensystem auf der Karte, Roboternamen als R1, R2 ..., Schaltfläche Bericht erstellen... (PDF / HTML / CSV); ohne Dialoge: weld_report (study, tolMm, tolDeg, robots, anonymize, axisCorner, maxItems, report, view, last)
Einstellungen > Konfigurieren...
Einstellungen > Client System Root festlegen
Einstellungen > Robots Machine Data Files festlegen
Einstellungen > Robots Archive Files festlegen
Einstellungen > Part Aggregator Size festlegen
Einstellungen > Nullpunktgröße festlegen
Einstellungen > Raster festlegen
Einstellungen > Roboterbeschriftung festlegen
Einstellungen > Weißen Hintergrund zeichnenui_set true / false
Hilfe > Dokumentation
Hilfe > Kapitel der Dokumentation > Erste Schritte
Hilfe > Kapitel der Dokumentation > 3D-Ansicht und Einstellungen
Hilfe > Kapitel der Dokumentation > Roboter, Werkzeuge und Verfahren
Hilfe > Kapitel der Dokumentation > Programme und Bahnen
Hilfe > Kapitel der Dokumentation > Zellensimulation
Hilfe > Kapitel der Dokumentation > Auto-Docking
Hilfe > Kapitel der Dokumentation > Arbeitsbereiche und Kollisionen
Hilfe > Kapitel der Dokumentation > Robot Cell Simulator Lite
Hilfe > Kapitel der Dokumentation > Lizenzen
Hilfe > Kapitel der Dokumentation > GPU und Einschränkungen
Hilfe > Lizenzen...
Hilfe > Sprache > Englishui_set true / false
Hilfe > Sprache > Deutschui_set true / false

Bedienfeld und Fenster

WoElementTypAPI
Hauptfenster3D-Ansicht (3D view, objectName view3d) – Kontextmenü: Fit All, weißer Hintergrund, Kollisionsstellen, Größe des Koordinatensystems, Hide / View Only / View All, Bahnen, Punktbeschriftungen, Koordinatensysteme der Punkte (Show point frames, Befehl view pointFrames), Display, Objekttypen; Tasten (Qt3D-Viewer): F Fit All, S Auswahl einpassen, 0 / Pos1 (Home) Standardansicht, 1..6 Normansichten, Pfeiltasten drehen um 15° (Umschalt + Pfeiltasten: verschieben), + / - und Bild↑ / Bild↓ (PgUp / PgDn) Zoom, Esc beendet eine erzwungene Operation oder hebt die Auswahl auf; keine Taste für die Perspektive (nur Menü View oder view perspective), kein W; Tasten im Komponentenbaum bewegen die Ansicht nicht; Variante mit dem JT-Leser: ui_key auf view3d ändert die Ansicht nicht (Black-Box-Test 2026-10-25); status: fps, viewSyncMs (wie das OSD der Ansichtsstatistik, -1 in der Variante mit dem JT-Leser)view3dui_context (danach ui_click auf den Eintrag); ui_key "keys"; Befehle view (Kamera, Schalter; orbit dreht die Kamera wie die Drehtaste), view_drag (Mausziehen in der Ansicht, zum Messen der Flüssigkeit) und scene_shot
MeldungsfensterShow information messages (number of messages) [0]Kontrollkästchenui_set true / false
MeldungsfensterShow warnings (number of warnings) [0]Kontrollkästchenui_set true / false
MeldungsfensterShow errors (number of errors) [0]Kontrollkästchenui_set true / false
Meldungsfenster(ohne Beschriftung - über id / Pfad)Textfensterui_get (Text)
KI-Agent(ohne Beschriftung - über id / Pfad) – der Chat; Links öffnen sich im WebbrowserTextfensterui_get (Text); eigener Befehl ai_chat (transcript)
KI-Agent(Kontextmenü des Chats) Kopieren, Alles auswählen, Größere Schrift (Strg + Mausrad), Kleinere Schrift, Ganze Unterhaltung kopieren, Leeren (neuer Chat)Menüui_context; dasselbe wie ai_chat last (transcript) und ai_chat newChat
KI-AgentNachricht an den Agenten (Enter sendet, Umschalt+Enter neue Zeile; /help - kurze Übersicht, /reload - Wissensdateien neu laden; /status, /run folge=125 … - ein direkter Befehl des Simulators: keine Tokens, er geht nicht an das Modell, der Simulator führt ihn sofort aus und zeigt die Antwort (JSON) in der Unterhaltung)Textfeldui_set "Text"; eigener Befehl ai_chat message (auch message "/help", "/reload", "/status")
KI-Agent(Kontextmenü des Nachrichtenfelds) Rückgängig, Wiederholen, Ausschneiden, Kopieren, Einfügen, Löschen, Alles auswählen, Größere Schrift (Strg + Mausrad), Kleinere Schrift, Leeren (Schriftgröße 7 … 32 pt, auch Strg+Plus / Strg+Minus; Einstellung RCS_Group/AiChat_FontSize)Menüui_context; ui_set "" (leeren)
KI-AgentSendenTasteui_click; ai_chat message; ui_set dockHeight / dockWidth (px) – Größe des angedockten Fensters des KI-Agenten (wie bei jedem Element in einem angedockten Fenster)
KI-AgentStoppTasteui_click; ai_chat stop
KI-AgentNeuer ChatTasteui_click; ai_chat newChat
KI-AgentVerbindung zum Modell: Einstellungen > Konfigurieren... > AI Agent (Anbieter, Adresse, API-Schlüssel, Modell)Tasteui_click
KI-Agent(Statuszeile in der Titelleiste des Fensters) Anbieter, Modell; während der Arbeit: Schritt, Fortschritt der Simulation (Zyklus x / y, Restzeit); Kontext NN %, Tokens des Chats, (NN % des Limits) – grün / orange / rotTextui_get (Text)
Bedienfeld(ohne Beschriftung - über id / Pfad) – Registerkarten: Model Browser, Einstellungen, Roboterachsen, Simulation, Robustheitstest, Bewegung, Zeiten, Arbeitsbereiche, Auto-Docking, SPS (Elemente der Registerkarte Robustheitstest: ui_list mit path "Robustheitstest"; eigener Befehl robust_test)Registerkartenui_set "Registerkarte"
Bedienfeld > SPS > Stationssteuerung (SPS)Simulation mit dem SPS-Programm steuernKontrollkästchenui_set true / false
Bedienfeld > SPS > Stationssteuerung (SPS)SPS-Programm bearbeiten...Tasteui_click
Bedienfeld > SPS > Stationssteuerung (SPS)Neu aus den Robotern der ZelleTasteui_click
Bedienfeld > SPS > Stationssteuerung (SPS)Signale E / A der Roboter...Tasteui_click
Bedienfeld > SPS > Stationssteuerung (SPS) > Prüfung vor dem LaufShow information messages (number of messages) [0]Kontrollkästchenui_set true / false
Bedienfeld > SPS > Stationssteuerung (SPS) > Prüfung vor dem LaufShow warnings (number of warnings) [5]Kontrollkästchenui_set true / false
Bedienfeld > SPS > Stationssteuerung (SPS) > Prüfung vor dem LaufShow errors (number of errors) [0]Kontrollkästchenui_set true / false
Bedienfeld > SPS > Stationssteuerung (SPS) > Prüfung vor dem Lauf(ohne Beschriftung - über id / Pfad)Textfensterui_get (Text)
Bedienfeld > SPS > Signale der RoboterSignaldatei:Textfeldui_set "Text"
Bedienfeld > SPS > Signale der RoboterEigene Signaldatei auswählen (z. B. eine Kopie für Ihre Anlage). Die Datei wird vor der Verwendung gTasteui_click
Bedienfeld > SPS > Signale der RoboterBearbeitenTasteui_click
Bedienfeld > SPS > Signale der RoboterDatei der InstallationTasteui_click
Bedienfeld > SPS > Signale der RoboterMehrTasteui_click
Bedienfeld > Auto-Docking > Werkzeugwechsel (VKRC-Programme)Werkzeugwechsel an den AndockpunktenKontrollkästchenui_set true / false
Bedienfeld > Auto-Docking > Werkzeugwechsel (VKRC-Programme)Werkzeug ablegen (DS abdocken): – Einträge: MAKRO, UP, AListeui_set "Eintrag"
Bedienfeld > Auto-Docking > Werkzeugwechsel (VKRC-Programme)Werkzeug ablegen (DS abdocken): (0 … 9999)Zahlui_set Zahl
Bedienfeld > Auto-Docking > Werkzeugwechsel (VKRC-Programme)= – Einträge: EIN, TRUEListeui_set "Eintrag"
Bedienfeld > Auto-Docking > Werkzeugwechsel (VKRC-Programme)Werkzeug aufnehmen (DS andocken): – Einträge: MAKRO, UP, AListeui_set "Eintrag"
Bedienfeld > Auto-Docking > Werkzeugwechsel (VKRC-Programme)Werkzeug aufnehmen (DS andocken): (0 … 9999)Zahlui_set Zahl
Bedienfeld > Auto-Docking > Werkzeugwechsel (VKRC-Programme)= – Einträge: EIN, TRUEListeui_set "Eintrag"
Bedienfeld > Auto-Docking > Werkzeugwechsel (VKRC-Programme)Max. Abstand des Werkzeugs vom Flansch: (50 … 3000)Zahlui_set Zahl
Bedienfeld > Auto-Docking > Werkzeugwechsel (VKRC-Programme)Programm: (1 … 999)Zahlui_set Zahl
Bedienfeld > Auto-Docking > Werkzeugwechsel (VKRC-Programme)Werkzeugwechsel auf allen RoboternTasteui_click
Bedienfeld > Auto-Docking > Werkzeugwechselregeln (alle Standards)Datei mit Werkzeugwechselregeln auswählen (gespeichert in den Einstellungen von Robot Cell SimulatorTasteui_click
Bedienfeld > Auto-Docking > Werkzeugwechselregeln (alle Standards)Regeln aus der Datei: ein regulärer Ausdruck auf den Text eines Programmbefehls VKRC: Fold-Titel, z.Baumui_view / ui_view_set / ui_context
Bedienfeld > Auto-Docking > Werkzeugwechselregeln (alle Standards)Regeldatei öffnen...Tasteui_click
Bedienfeld > Auto-Docking > Werkzeugwechselregeln (alle Standards)Integrierte RegelnTasteui_click
Bedienfeld > Auto-Docking > Werkzeugwechselregeln (alle Standards)Integrierte Regeln speichern unter...Tasteui_click
Bedienfeld > Auto-Docking > Werkzeugwechselregeln (alle Standards)Im Editor bearbeitenTasteui_click
Bedienfeld > Auto-Docking > Werkzeugwechselregeln (alle Standards)Neu ladenTasteui_click
Bedienfeld > Auto-Docking > Werkzeuge an den RoboternAlle Werkzeuge von allen Robotern lösenTasteui_click
Bedienfeld > Auto-Docking > Werkzeuge an den RoboternStandardwerkzeuge an alle Roboter anbauenTasteui_click
Bedienfeld > ArbeitsbereicheAus den Bahnen ihrer Programme berechnete Arbeitsbereiche der Roboter. Grün = von einem Roboter genutzt, gelb&hellip;Baumui_view / ui_view_set / ui_context
Bedienfeld > ArbeitsbereicheAlle auswählenTasteui_click
Bedienfeld > ArbeitsbereicheKeine auswählenTasteui_click
Bedienfeld > ArbeitsbereicheAuswahl umkehrenTasteui_click
Bedienfeld > Arbeitsbereiche > BerechnungRaster: – Einträge: 50 mm, 100 mm, 150 mm, 200 mm, 300 mmListeui_set "Eintrag"
Bedienfeld > Arbeitsbereiche > BerechnungGliedradius: (0 … 1000)Zahlui_set Zahl
Bedienfeld > Arbeitsbereiche > BerechnungAm Flansch angehängtes Werkzeug einbeziehen (3D-Modell)Kontrollkästchenui_set true / false
Bedienfeld > Arbeitsbereiche > BerechnungIn den Punkten aufgerufene Unterprogramme einbeziehen (UP)Kontrollkästchenui_set true / false
Bedienfeld > Arbeitsbereiche > BerechnungWürfelraster (Achse der Glieder + Radius) - schnellOptionui_set true
Bedienfeld > Arbeitsbereiche > BerechnungDreiecke der 3D-Modelle (reale Form) - dauert längerOptionui_set true
Bedienfeld > Arbeitsbereiche > BerechnungBerechnenTasteui_click
Bedienfeld > Arbeitsbereiche > BerechnungLeerenTasteui_click
Bedienfeld > Arbeitsbereiche > BerechnungKollisionsmatrix...Tasteui_click
Bedienfeld > Arbeitsbereiche > AnzeigeArbeitsbereiche anzeigenKontrollkästchenui_set true / false
Bedienfeld > Arbeitsbereiche > AnzeigeNur gemeinsame Bereiche anzeigen (gelb / rot)Kontrollkästchenui_set true / false
Bedienfeld > Arbeitsbereiche > AnzeigeTransparenz: (10 … 95)Schiebereglerui_set Zahl
Bedienfeld > Arbeitsbereiche > AnzeigeProgrammbahn in VerriegelungsfarbenKontrollkästchenui_set true / false
Bedienfeld > Arbeitsbereiche > Einfahrten ohne VerriegelungPunkte, an denen ein Roboter ohne Verriegelungsanforderung in einen mit einem anderen Roboter gemeinBaumui_view / ui_view_set / ui_context
Bedienfeld > Arbeitsbereiche > Einfahrten ohne VerriegelungVerriegelungen einfügen...Tasteui_click
Bedienfeld > Arbeitsbereiche > Einfahrten ohne VerriegelungVerriegelungen prüfen...Tasteui_click
Bedienfeld > ArbeitsbereicheAnonymisierte Studie für KI... – Fragen vor dem Speichern: Verriegelungskommentare und Langtexte; Die in der letzten Simulation gefundenen Kollisionsgefahren hinzufügen (Verriegelungen prüfen: COLLISION, Simulation: collisionCheck)? [Ja, die Wahl wird gespeichert] (siehe Anonymisierte Studie)Tasteeigener Befehl anon_study (file, check, run, show, texts, collisions true / false – false = ohne die Kollisionsgefahren, Blindtest der KI)
Bedienfeld > ZeitenBerichtshinweise:Textfeldui_set "Text"
Bedienfeld > ZeitenEigene Hinweisdatei wählen (z. B. eine Kopie mit den Texten Ihrer Anlage oder in einer anderen SpracTasteui_click
Bedienfeld > ZeitenBearbeitenTasteui_click
Bedienfeld > ZeitenDatei der InstallationTasteui_click
Bedienfeld > Zeiten(ohne Beschriftung - über id / Pfad)Baumui_view / ui_view_set / ui_context
Bedienfeld > ZeitenAlle aufklappenTasteui_click
Bedienfeld > ZeitenExportieren...Tasteui_click
Bedienfeld > ZeitenBericht...Tasteui_click
Bedienfeld > ZeitenSignal-Zeitachse...Tasteui_click; signal_timeline window true
Signal-ZeitachseBaum der Signale (ankreuzen)Kontrollkästchensignal_timeline select / add / remove; Simulationsdatei SignalTimeline
Signal-Zeitachsein jedem Stationslauf aufzeichnenKontrollkästchensignal_timeline record true / false
Signal-ZeitachseKlick in die Zeitachse (Cursor), Text darunterDiagrammsignal_timeline why (Zeit) + robot
Signal-ZeitachseRoboter zum Cursor / 3D folgt dem CursorTaste / Kontrollkästchensignal_timeline showAt (Zeit)
Signal-ZeitachseGanzer Lauf, Mausrad / Ziehen (Zeitfenster)Taste / Diagrammsignal_timeline from, to
Signal-ZeitachseAuswahl löschenTastesignal_timeline select []
Signal-ZeitachseSpeichern... (CSV / PDF / HTML), Roboternamen als R1..RnTaste / Kontrollkästchensignal_timeline export, anonymize
Signal-ZeitachseAktualisierenTasteui_click; signal_timeline
Bedienfeld > ZeitenTaktzeitreserve...Tasteui_click; cycle_reserve window true
TaktzeitreserveNutzung der Wartezeit / Override nicht unter / erst ab (%)Zahlencycle_reserve share, minOverride, minGain; Simulationsdatei CycleReserve
TaktzeitreserveLetzten Lauf analysierenTastecycle_reserve action analyze
TaktzeitreserveNutzen (ankreuzen), Override [%] (Doppelklick)Tabellecycle_reserve use [{robot, point, use, override}]
TaktzeitreserveKontrolllauf mit diesen Geschwindigkeiten / Kein KontrolllaufTastencycle_reserve action test / cancel (danach run)
TaktzeitreserveBericht speichern... (PDF / HTML / CSV), Roboternamen als R1..RnTaste / Kontrollkästchencycle_reserve export, anonymize
TaktzeitreserveAktualisierenTasteui_click; cycle_reserve
Bedienfeld > Bewegung > BewegungReale Bewegung (Bewegungsplaner)Kontrollkästchenui_set true / false
Bedienfeld > Bewegung > BewegungEchtzeit (1:1)Tasteui_click
Bedienfeld > Bewegung > Parameter des BewegungsplanersProgramm-Override: (1 … 100)Zahlui_set Zahl
Bedienfeld > Bewegung > Parameter des BewegungsplanersPTP-Beschleunigungszeit: (0.05 … 3)Zahlui_set Zahl
Bedienfeld > Bewegung > Parameter des BewegungsplanersBahnbeschleunigung (LIN / CIRC): (0 … 20000)Zahlui_set Zahl
Bedienfeld > Bewegung > Parameter des BewegungsplanersOrientierungsgeschwindigkeit: (10 … 1000)Zahlui_set Zahl
Bedienfeld > Bewegung > Parameter des BewegungsplanersÜberschleifen der EckenKontrollkästchenui_set true / false
Bedienfeld > Bewegung > Parameter des BewegungsplanersStandardwerteTasteui_click
Bedienfeld > Bewegung > ProgrammbahnReale Bahn zeichnen (PTP / LIN / CIRC, Überschleifen)Kontrollkästchenui_set true / false
Bedienfeld > BewegungMaschinendaten des gewählten RobotersTasteui_click
Bedienfeld > Bewegung > Bewegungszeiten(ohne Beschriftung - über id / Pfad)Baumui_view / ui_view_set / ui_context
Bedienfeld > Bewegung > BewegungszeitenExportieren...Tasteui_click
Bedienfeld > Bewegung > BewegungszeitenLeerenTasteui_click
Bedienfeld > Simulation > Programm auf allen Robotern startenProgramm: – Einträge: Folge, UPListeui_set "Eintrag"
Bedienfeld > Simulation > Programm auf allen Robotern startenProgrammnummer, z. B. 125 für Folge125 (1 … 9999)Zahlui_set Zahl
Bedienfeld > Simulation > Programm auf allen Robotern startenAnzahl der Zyklen aus dem Start-Baustein des SPS-Programms (Reiter SPS) (1 … 999)Zahlui_set Zahl
Bedienfeld > Simulation > Programm auf allen Robotern startenVerriegelungssignale beachten (A8n / Makro20 / A4n)Kontrollkästchenui_set true / false
Bedienfeld > Simulation > Programm auf allen Robotern startenVerriegelungskarte prüfenTasteui_click; Befehl sim_action "check_interlock_map"
Bedienfeld > Simulation > Programm auf allen Robotern startenSimulation bei Kollisionsgefahr anhaltenKontrollkästchenui_set true / false; sim_options stopAtCollisionRisk
Bedienfeld > Simulation > Programm auf allen Robotern startenweiter nach N sDrehfeldui_set 0..600; sim_options autoResume; Simulationsdatei Options autoResumeSec
Bedienfeld > Simulation > Programm auf allen Robotern startenKollisionsgefahren...Tasteui_click
Bedienfeld > Simulation > Programm auf allen Robotern startenLive-3D-Kollisionsprüfung (Modelle der Roboter und Werkzeuge, langsamer)Kontrollkästchenui_set true / false; live_check on
Bedienfeld > Simulation > Programm auf allen Robotern startenZelle (10 … 100 mm)Zahlui_set Zahl; live_check cell
Bedienfeld > Simulation > Programm auf allen Robotern startenDummy-Werkzeugkörper R (10 … 300 mm)Zahlui_set Zahl; live_check capsule
Bedienfeld > Simulation > Programm auf allen Robotern startenAbstand bis (50 … 1000 mm)Zahlui_set Zahl; live_check range
Bedienfeld > Simulation > Programm auf allen Robotern startenWarnung unter (0 = aus … 500 mm, Standard 30)Zahlui_set Zahl; live_check warn
Bedienfeld > Simulation > Programm auf allen Robotern startenKontakt bis (0 … 50 mm, Standard 5)Zahlui_set Zahl; live_check contact; Simulationsdatei Options live3dContact
Bedienfeld > Simulation > Programm auf allen Robotern startenauch bei Annäherung unter 'Warnung unter' anhaltenKontrollkästchenui_set true / false; live_check stopNear; Simulationsdatei Options live3dStopNear
Bedienfeld > Simulation > Programm auf allen Robotern startenPaare ignorieren, die sich beim Start schon berühren (Warnung)Kontrollkästchenui_set true / false; live_check ignoreStartContacts; Simulationsdatei Options live3dIgnoreStart
Bedienfeld > Simulation > Programm auf allen Robotern startenGeringste Abstände...Schaltflächeui_click; live_check window true; Werte: live_check closest
Geringste Abstände der Roboter (Live 3D)Doppelklick auf eine Zeile / auf WoTabellelive_check show {robot, partner, what 3d / robot / partner}
Geringste Abstände der Roboter (Live 3D)AktualisierenSchaltflächeui_click; live_check closest
Geringste Abstände der Roboter (Live 3D)Bericht speichern... (PDF / HTML / CSV)Schaltflächelive_check export, format pdf / html / csv
Geringste Abstände der Roboter (Live 3D)Robotername als R1..RnKontrollkästchenlive_check anonymize true / false
Bedienfeld > Simulation > Programm auf allen Robotern startenPrüfung in eigenem ThreadKontrollkästchenui_set true / false; live_check thread
Bedienfeld > Simulation > Programm auf allen Robotern startenmehrere Prozessorkerne für eine PrüfungKontrollkästchenui_set true / false; live_check parallel
Bedienfeld > Simulation > Programm auf allen Robotern startenfester Schritt: die Simulationsuhr wartet auf jede PrüfungKontrollkästchenui_set true / false; live_check grid
Bedienfeld > Simulation > Programm auf allen Robotern startenSchritt (10 … 500 ms)Zahlui_set Zahl; live_check stepMs; Ergebnis: live_check stats (checks, checkMsP50 / P95, gapAvgS / gapMaxS, nearMoveMaxMm / nearMoveP95Mm, clockWaitS, recommendedStepMs, maxSpeedWithoutWait)
Bedienfeld > Simulation > Programm auf allen Robotern startenFreie Fahrt - alle Bedingungen ignorieren (SPS, Verriegelungen, WARTE BIS, FB, Kollisionen)Kontrollkästchenui_set true / false; sim_options freeRun
Bedienfeld > Simulation > Programm auf allen Robotern startenSzene zeichnen (16, 50, 100, 250, 1000 ms)Listeui_set Index; sim_options redrawMs
Bedienfeld > Simulation > Programm auf allen Robotern startenAlle gemeinsam bei 'Warte auf Folgenstart' startenKontrollkästchenui_set true / false
Bedienfeld > Simulation > Programm auf allen Robotern startenProgrammzustand über den Robotern anzeigenKontrollkästchenui_set true / false
Bedienfeld > Simulation > Programm auf allen Robotern startenStatusleuchte...Tasteui_click
Bedienfeld > Simulation > Programm auf allen Robotern startenKollisionskarte anzeigenKontrollkästchenui_set true / false
Bedienfeld > Simulation > Programm auf allen Robotern startenPosition der Kollisionskarte in der 3D-Ansicht – Einträge: auf dem Boden, oben (unter den Statusleuchten), am Robotersockel (Achse 1)Listeui_set "Eintrag"
Bedienfeld > Simulation > Programm auf allen Robotern startenKonsolenmeldungen...Tasteui_click
Bedienfeld > SimulationGeschwindigkeit: (0 … 400)Schiebereglerui_set Zahl
Bedienfeld > SimulationAnimationsgeschwindigkeit für alle Roboter: 0 % = Pause, 100 % = Echtzeit, bis 400 % = schneller. Mi (0 … 400)Zahlui_set Zahl
Bedienfeld > Simulation25 %Tasteui_click
Bedienfeld > Simulation50 %Tasteui_click
Bedienfeld > Simulation100 %Tasteui_click
Bedienfeld > Simulation200 %Tasteui_click
Bedienfeld > Simulation400 %Tasteui_click
Bedienfeld > SimulationSPSTasteui_set true / false
Bedienfeld > SimulationAuf allen Robotern startenTasteui_click; bei eingeschalteter SPS und einer anderen Programmnummer im Feld Program eine Rückfrage (Continue setzt die Nummer des SPS-Programms und startet, Cancel startet nicht) – der API-Befehl run liefert denselben Text als Fehler Nicht gestartet: ... (Felder spsFolge, spsCycles)
Bedienfeld > SimulationPauseTasteui_set true / false
Bedienfeld > SimulationAlle stoppenTasteui_click
Bedienfeld > SimulationWeiter (Quitt)Tasteui_click
Bedienfeld > SimulationQuitt, wenn alle Roboter wartenKontrollkästchenui_set true / false
Bedienfeld > SimulationFolge 123Tasteui_click
Bedienfeld > SimulationFolge 125Tasteui_click
Bedienfeld > SimulationDie Programme der Roboter werden im Hintergrund vorbereitet (einmal geparst) - die Simulation starteFortschrittui_get (nur lesen)
Bedienfeld > Simulation > ProgrammablaufUP-Aufrufe: – Einträge: Nicht ausführen, Nur unbedingte Aufrufe (= EIN), Alle Aufrufe (Bedingungen ignoriert)Listeui_set "Eintrag"
Bedienfeld > Simulation > ProgrammablaufBei 'WARTE BIS AUS' anhalten und auf Weiter wartenKontrollkästchenui_set true / false
Bedienfeld > Simulation > ProgrammablaufBei jedem 'WARTE BIS' anhalten und auf Weiter wartenKontrollkästchenui_set true / false
Bedienfeld > Simulation > ProgrammablaufFahrbedingungen ignorieren (FB PSPS / FB ONL)Kontrollkästchenui_set true / false; sim_options ignoreMotionConditions
Bedienfeld > Simulation > ProgrammablaufAn Haltepunkten anhaltenKontrollkästchenui_set true / false
Bedienfeld > Simulation > ProgrammablaufBei WARTE BIS anhalten:Textfeldui_set "Text"
Bedienfeld > Simulation > Programmablauf(icon)Tasteui_click
Bedienfeld > Simulation > Programmablauf...Tasteui_click
Bedienfeld > Simulation > Programmablaufeinmal pro TaktKontrollkästchenui_set true / false
Bedienfeld > Simulation > Programmablauf > ProgrammregelnExclude UP: Aufrufe dieser UP-Nummern werden übersprungen (z. B. 101 oder 101, 105-108). Exclude MAKTabelleui_view / ui_view_set / ui_context
Bedienfeld > Simulation > Programmablauf > ProgrammregelnZellen der Regeltabelle: ui_view_set row / columnListeui_view_set
Bedienfeld > Simulation > Programmablauf > ProgrammregelnHinzufügenTasteui_click
Bedienfeld > Simulation > Programmablauf > ProgrammregelnEntfernenTasteui_click
Bedienfeld > Simulation > Programmablauf > ProgrammregelnPOT-Zeiten importieren...Tasteui_click
Bedienfeld > Simulation > ProgrammablaufAchswerte jedes Punkts in der Konsole anzeigenKontrollkästchenui_set true / false
Bedienfeld > RoboterachsenA1 (0 … 0)Schiebereglerui_set Zahl
Bedienfeld > RoboterachsenA2 (0 … 0)Schiebereglerui_set Zahl
Bedienfeld > RoboterachsenA3 (0 … 0)Schiebereglerui_set Zahl
Bedienfeld > RoboterachsenA4 (0 … 0)Schiebereglerui_set Zahl
Bedienfeld > RoboterachsenA5 (0 … 0)Schiebereglerui_set Zahl
Bedienfeld > RoboterachsenA6 (0 … 0)Schiebereglerui_set Zahl
Bedienfeld > RoboterachsenE1 (0 … 0)Schiebereglerui_set Zahl
Bedienfeld > RoboterachsenRoboterachse A1 [Grad] (0 … 0)Zahlui_set Zahl
Bedienfeld > RoboterachsenRoboterachse A2 [Grad] (0 … 0)Zahlui_set Zahl
Bedienfeld > RoboterachsenRoboterachse A3 [Grad] (0 … 0)Zahlui_set Zahl
Bedienfeld > RoboterachsenRoboterachse A4 [Grad] (0 … 0)Zahlui_set Zahl
Bedienfeld > RoboterachsenRoboterachse A5 [Grad] (0 … 0)Zahlui_set Zahl
Bedienfeld > RoboterachsenRoboterachse A6 [Grad] (0 … 0)Zahlui_set Zahl
Bedienfeld > RoboterachsenZusatzachse E1 - Lineareinheit (7. Achse) [mm] (0 … 0)Zahlui_set Zahl
Bedienfeld > Roboterachsen > Kartesisch (TCP)WerkzeugListeui_set "Eintrag"; Befehl robot tcp / moveTcp {tool}
Bedienfeld > Roboterachsen > Kartesisch (TCP)BasisListeui_set "Eintrag"; Befehl robot tcp / moveTcp {base}
Bedienfeld > Roboterachsen > Kartesisch (TCP)verfahren - (TCP-Position X in der ausgewählten Basis [mm])Tasteui_click
Bedienfeld > Roboterachsen > Kartesisch (TCP)verfahren + (TCP-Position X in der ausgewählten Basis [mm])Tasteui_click
Bedienfeld > Roboterachsen > Kartesisch (TCP)TCP-Position X in der ausgewählten Basis [mm] (-100000 … 100000)Zahlui_set Zahl
Bedienfeld > Roboterachsen > Kartesisch (TCP)verfahren - (TCP-Position Y in der ausgewählten Basis [mm])Tasteui_click
Bedienfeld > Roboterachsen > Kartesisch (TCP)verfahren + (TCP-Position Y in der ausgewählten Basis [mm])Tasteui_click
Bedienfeld > Roboterachsen > Kartesisch (TCP)TCP-Position Y in der ausgewählten Basis [mm] (-100000 … 100000)Zahlui_set Zahl
Bedienfeld > Roboterachsen > Kartesisch (TCP)verfahren - (TCP-Position Z in der ausgewählten Basis [mm])Tasteui_click
Bedienfeld > Roboterachsen > Kartesisch (TCP)verfahren + (TCP-Position Z in der ausgewählten Basis [mm])Tasteui_click
Bedienfeld > Roboterachsen > Kartesisch (TCP)TCP-Position Z in der ausgewählten Basis [mm] (-100000 … 100000)Zahlui_set Zahl
Bedienfeld > Roboterachsen > Kartesisch (TCP)verfahren - (TCP-Orientierung A in der ausgewählten Basis [Grad])Tasteui_click
Bedienfeld > Roboterachsen > Kartesisch (TCP)verfahren + (TCP-Orientierung A in der ausgewählten Basis [Grad])Tasteui_click
Bedienfeld > Roboterachsen > Kartesisch (TCP)TCP-Orientierung A in der ausgewählten Basis [Grad] (-180 … 180)Zahlui_set Zahl
Bedienfeld > Roboterachsen > Kartesisch (TCP)verfahren - (TCP-Orientierung B in der ausgewählten Basis [Grad])Tasteui_click
Bedienfeld > Roboterachsen > Kartesisch (TCP)verfahren + (TCP-Orientierung B in der ausgewählten Basis [Grad])Tasteui_click
Bedienfeld > Roboterachsen > Kartesisch (TCP)TCP-Orientierung B in der ausgewählten Basis [Grad] (-180 … 180)Zahlui_set Zahl
Bedienfeld > Roboterachsen > Kartesisch (TCP)verfahren - (TCP-Orientierung C in der ausgewählten Basis [Grad])Tasteui_click
Bedienfeld > Roboterachsen > Kartesisch (TCP)verfahren + (TCP-Orientierung C in der ausgewählten Basis [Grad])Tasteui_click
Bedienfeld > Roboterachsen > Kartesisch (TCP)TCP-Orientierung C in der ausgewählten Basis [Grad] (-180 … 180)Zahlui_set Zahl
Bedienfeld > Roboterachsen > Kartesisch (TCP)Schritt – Einträge: 0.1, 1, 10, 100Listeui_set "Eintrag"
Bedienfeld > Roboterachsen > Kartesisch (TCP)TCP-Position beim Verfahren von E1 beibehaltenKontrollkästchenui_set true / false
Bedienfeld > Roboterachsen > Kartesisch (TCP)TCP-Koordinatensystem anzeigenKontrollkästchenui_set true / false
Bedienfeld > Roboterachsen > Kartesisch (TCP)Basiskoordinatensystem anzeigenKontrollkästchenui_set true / false
Bedienfeld > Einstellungen > TransparenzTransparente Komponenten (außer Robotern und ihren Werkzeugen)Kontrollkästchenui_set true / false
Bedienfeld > Einstellungen > TransparenzTransparenz: (0 … 100)Schiebereglerui_set Zahl
Bedienfeld > Einstellungen > Transparenz80 %Baumui_view / ui_view_set / ui_context
Bedienfeld > Einstellungen > TransparenzAlleTasteui_click
Bedienfeld > Einstellungen > TransparenzKeineTasteui_click
Bedienfeld > Einstellungen > TransparenzÜbernehmenTasteui_click
Bedienfeld > Einstellungen > TransparenzZurücksetzenTasteui_click
Bedienfeld > Einstellungen > CullingView Culling aktivierenKontrollkästchenui_set true / false
Bedienfeld > Einstellungen > CullingSize Culling aktivierenKontrollkästchenui_set true / false
Bedienfeld > Einstellungen > CullingStatistik-OSDKontrollkästchenui_set true / false
Bedienfeld > Einstellungen > Level of DetailQualität: (0 … 100)Schiebereglerui_set Zahl
Bedienfeld > Einstellungen > Auswahl...Tasteui_click
Bedienfeld > Einstellungen > AuswahlLinksTasteui_set true / false
Bedienfeld > Einstellungen > AuswahlMitteTasteui_set true / false
Bedienfeld > Einstellungen > AuswahlRechtsTasteui_set true / false
Bedienfeld > Einstellungen > KamerasteuerungAnimierte KameraübergängeKontrollkästchenui_set true / false
Bedienfeld > Einstellungen > KamerasteuerungAutomatisch alles einpassenKontrollkästchenui_set true / false
Bedienfeld > Einstellungen > KamerasteuerungLinksTasteui_set true / false
Bedienfeld > Einstellungen > KamerasteuerungMitteTasteui_set true / false
Bedienfeld > Einstellungen > KamerasteuerungRechtsTasteui_set true / false
Bedienfeld > Einstellungen > KamerasteuerungLinksTasteui_set true / false
Bedienfeld > Einstellungen > KamerasteuerungMitteTasteui_set true / false
Bedienfeld > Einstellungen > KamerasteuerungRechtsTasteui_set true / false
Bedienfeld > Einstellungen > KamerasteuerungLinksTasteui_set true / false
Bedienfeld > Einstellungen > KamerasteuerungMitteTasteui_set true / false
Bedienfeld > Einstellungen > KamerasteuerungRechtsTasteui_set true / false
Bedienfeld > Einstellungen > KamerasteuerungZoomen mit MausradKontrollkästchenui_set true / false
Bedienfeld > Model Browser(ohne Beschriftung - über id / Pfad)Baumui_view / ui_view_set / ui_context
Bedienfeld > Model Browser(Kontextmenü eines Roboters) Werkzeugmodell (JT / STEP / STL / glTF)... (Tool model (JT / STEP / STL / glTF)...) – Dialog: Modelldatei (.jt, .gltf, .glb, binäres .stl, .stp, .step), X Y Z [mm], A B C [deg] (Ursprung des Modells relativ zum Flansch), zusätzliches Element am Flansch (Vorrichtung, z. B. Werkzeugwechsler) – das Werkzeug bleibtMenüui_context; eigener Befehl tool_model (robot, file, pos {x, y, z, a, b, c}, fixture) – Dummy-Werkzeug entfernt, mit der Simulation und der Sitzung gespeichert
Bedienfeld > Model Browser(Kontextmenü eines Roboters) Alle Programme suchen (Find all programs) – der Programmbaum des Roboters wird neu aus seinem Archiv aufgebaut (neue und geänderte Folge- / UP-Dateien)Menüui_context; Befehl robot rebuildPrograms true (Antwort programsRebuilt)
Bedienfeld > Model BrowserFilterTextfeldui_set "Text"
Bedienfeld > Model Browser(icon)Tasteui_click
Programme und Eigenschaften(ohne Beschriftung - über id / Pfad) – Registerkarten: Programme, Knotenattr.Registerkartenui_set "Registerkarte"
Programme und Eigenschaften > Programme(ohne Beschriftung - über id / Pfad)Baumui_view / ui_view_set / ui_context
Programme und Eigenschaften > ProgrammeGeschwindigkeit 400 % (0 … 400)Schiebereglerui_set Zahl
Programme und Eigenschaften > ProgrammeProgramm startenTasteui_click
Programme und Eigenschaften > ProgrammeTCP-Position und aktuelle Position des montierten Werkzeugs während der Bewegung aufzeichnenTasteui_set true / false
Programme und Eigenschaften > ProgrammeZum vorherigen Punkt fahrenTasteui_click
Programme und Eigenschaften > ProgrammeZum nächsten Punkt fahrenTasteui_click
Programme und Eigenschaften > ProgrammeFahrenTasteui_click
Programme und Eigenschaften > ProgrammeProgramm stoppenTasteui_click
Programme und Eigenschaften > ProgrammeTouch upTasteui_click
Programme und Eigenschaften > ProgrammeEditorTasteui_click
Programme und Eigenschaften > ProgrammeDem Editor folgenKontrollkästchenui_set true / false
Datei öffnenTasteui_click
Datei einfügenTasteui_click
Neue SzeneTasteui_click
Alles einpassenTasteui_click
ZoomenTasteui_set true / false
VerschiebenTasteui_set true / false
DrehenTasteui_set true / false
Achsen anzeigenTasteui_set true / false
PerspektivmodusTasteui_set true / false
StandardTasteui_click
ObenTasteui_click
UntenTasteui_click
LinksTasteui_click
RechtsTasteui_click
VorneTasteui_click
HintenTasteui_click
ScreenshotTasteui_click

Fenster der Wettläufe (race_study)

Am Ende einer Stationssimulation oder eines Robustheitstests mit Wettläufen kommt das Fenster Wettlauf gefunden; nach der Simulation beider Reihenfolgen das Fenster Simulation beider Reihenfolgen - Ergebnis (siehe Wettläufe: Vorschlag und Simulation beider Reihenfolgen). Die Simulation ändert das SPS-Programm nie von selbst. Jedes Element dieser Fenster hat den Befehl race_study; Fehlermeldungen sind immer englisch.

WoElementTypAPI
Wettlauf gefunden(Tabelle) Bereich | Zuerst in der Simulation | Zweiter | Kleinster Abstand [s]Tabellerace_study status: proposals [{race, zone, first, whereFirst, second, whereSecond, difference}]
Wettlauf gefundenTakte pro Lauf: (1 … 20) [3]Zahlrace_study start: cycles
Wettlauf gefundenBeide Reihenfolgen simulierenTasterace_study start (races [Indizes], fehlt = alle; cycles 1..20, Standard 3); Lizenz Simulation, aktives SPS-Programm
Wettlauf gefundenSchutzbausteine hinzufügenTasterace_study add_blocks (races [Indizes], fehlt = alle); Antwort added [Texte]
Wettlauf gefundenSchließenTasteui_click (es wird nichts geändert)
Registerkarte Robustness testStop (während beide Reihenfolgen simuliert werden)Tasterace_study stop: das SPS-Programm wird wiederhergestellt, Ergebnis der fertigen Läufe
Simulation beider Reihenfolgen - Ergebnis(Tabelle) Bereich | A: Reihenfolge der Simulation | B: Roboter vertauscht | BehaltenTabellerace_study status: result [{race, zone, first, whereFirst, second, whereSecond, difference, A {avg, min, max, cycles, waitTotal, collisionRisks, interrupted, done}, B {...}, recommended "A" | "B" | "none"}]
Simulation beider Reihenfolgen - ErgebnisBehalten (A: R1 zuerst | B: R2 zuerst | kein Baustein)Liste (pro Zeile)race_study apply: choices ["A" | "B" | "none", ...] – eine pro Wettlauf des Ergebnisses
Simulation beider Reihenfolgen - ErgebnisGewählte Bausteine hinzufügenTasterace_study apply; Antwort added
Simulation beider Reihenfolgen - ErgebnisSchließen (SPS-Programm unverändert)Tasteui_click

Der Befehl:

AufrufBedeutung
{"cmd":"race_study"} oder "action":"status"lesend, auch ohne Lizenz API / CLI: proposals, active (true, solange beide Reihenfolgen simuliert werden), run / runs (während active), result, pendingBlocks (Bausteine, die auf die Entscheidung bei save warten)
{"cmd":"race_study","action":"add_blocks","races":[0]}Bausteine 'Interlock priority' mit der Reihenfolge der Simulation; races fehlt = alle; Antwort added [Texte]
{"cmd":"race_study","action":"start","cycles":3}Simulation beider Reihenfolgen: für jeden Wettlauf 2 Läufe (A = Reihenfolge der Simulation, B = Roboter getauscht); Fortschritt und Protokoll auf der Registerkarte Robustness test, Bericht in Dokumente\RCS_Robustheitstest\race_study
{"cmd":"race_study","action":"stop"}stoppt sie; das SPS-Programm wird wiederhergestellt
{"cmd":"race_study","action":"apply","choices":["A","none"]}die gewählten Bausteine in das SPS-Programm (Kommentar mit den Ergebnissen beider Varianten; ein älterer Baustein desselben Paars im Bereich wird ersetzt); Antwort added

Typischer Ablauf eines Agenten: run → auf das Ende warten (status) → race_study status → start {cycles: 3} → warten, bis active false ist → result lesen → apply {choices: [...]} → save {raceBlocks: "keep"}. Die Antwort von race_rules enthält auch proposals.

Seit 2026-10-25 werden die Fenster dieses Abschnitts (Wettlauf gefunden, Wettläufe der Anforderungen, Simulation beider Reihenfolgen - Ergebnis) sowie Simulation beendet / Kollisionsgefahr in der Simulation am Ende eines über die API gestarteten oder angehaltenen Laufs, Tests oder einer Studie nicht geöffnet – ihren Inhalt statt mit den ui_*-Befehlen mit race_study status, run_data und status.lastRunMessages lesen. In der GUI ist immer nur ein Fenster Simulation beendet offen: das nächste Ende eines Laufs ersetzt seinen Text.

Einstellungen (Einstellungen > Konfigurieren...)

Mit ui_click auf Einstellungen > Konfigurieren... öffnen, Elemente ändern, mit OK bestätigen; dieselben Werte stehen auch als Schlüssel von RCS_Group für settings_get / settings_set bereit.

WoElementTypAPI
(ohne Beschriftung - über id / Pfad) – Registerkarten: Signalbeschreibungen, Simulation, Kollisionsbericht, Verriegelungskommentare, KI-Agent (Elemente der Registerkarten Kollisionsbericht und Verriegelungskommentare: ui_list mit window "Einstellungen")Registerkartenui_set "Registerkarte"
KI-AgentBefehls-API des Robot Cell Simulator für den KI-Agenten und Skripte (\\.\pipe\DReS_RCS_API)Kontrollkästchenui_set true / false
KI-AgentClient-Skript des Simulators:Textfeldui_set "Text"
KI-AgentClient-Skript des Simulators wählenTasteui_click
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellAnbieter: (Anthropic API (Claude) | OpenAI-kompatible API (VW LLMaaS, Azure OpenAI, OpenAI, lokales Ollama) | Claude Code - Ihr claude.ai-Konto (nur eigene Nutzung))Listeui_set "Eintrag"; Schlüssel AiChat_Provider (anthropic | openai | claudecode)
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellProgramm Claude Code: (leer = automatisch gefunden: PATH oder %USERPROFILE%\.local\bin\claude.exe; nur für Claude Code)Textfeldui_set "Text"; Schlüssel AiChat_ClaudePath
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellPython: (Python 3 für den MCP-Server AIAgent\vera_mcp.py) [python]; nur für Claude CodeTextfeldui_set "Text"; Schlüssel AiChat_Python
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellAdresse: (mit der Standardadresse des Anbieters ausgefüllt: https://api.anthropic.com/v1/messages | https://api.openai.com/v1/chat/completions; eine eigene Adresse bleibt)Textfeldui_set "Text"; Schlüssel AiChat_Url
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellAPI-Schlüssel / Token:Textfeld (Passwort)ui_set "Text"; gespeichert verschleiert als AiChat_Key (nicht über settings_set setzen)
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellHeader des Schlüssels: (Authorization | z. B. api-key)Textfeldui_set "Text"; Schlüssel AiChat_AuthHeader
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellModell: (leer = claude-sonnet-5-5 / gpt-4.1 / Standard von Claude Code, z. B. sonnet, opus)Textfeldui_set "Text"; Schlüssel AiChat_Model
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellSchritte pro Nachricht: (5 … 500) [60]Zahlui_set Zahl; Schlüssel AiChat_MaxSteps
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellKontextfenster [Tokens]: (8000 … 2000000) [200000]Zahlui_set Zahl; Schlüssel AiChat_Context
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellToken-Limit pro Chat: (0 = ohne Limit … 100000000) [ohne Limit]; nur ein Hinweis in der StatuszeileZahlui_set Zahl; Schlüssel AiChat_Budget
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellAnonymer Modus - das Modell sieht R1, R2 ..., <file N> und <name> statt der Roboternamen, Dateipfade und Kennungen der Anlage [aus]; eine Änderung beginnt einen neuen Chat (siehe Anonymer Modus)Kontrollkästchenui_set true / false; Schlüssel AiChat_Anonymous; ai_chat anonymous true / false; Chat /anonymous on | off
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellWissen der KI beim Start laden (Aufwärmen im Hintergrund) – etwa 8 s nach dem Start werden die Wissensdateien gelesen und einmal Claude Code (claude --version) und Python gestartet; keine Anfrage an das Modell, keine Token; ohne Verbindung zum Modell passiert nichts [aus]Kontrollkästchenui_set true / false; Schlüssel AiChat_WarmUp; ai_chat warmUp true / false (Antwort warmUp, connectionConfigured)
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellWissensdateien: – Wissensdateien des Agenten (Markdown oder Text), in dieser Reihenfolge an das Modell gesendet [template\RCS\AIAgent\rcs_agent_instructions.md]Listeui_view / ui_view_set (select); Schlüssel AiChat_Knowledge (Liste von Pfaden)
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellHinzufügen...Tasteui_click (Dateidialog, mehrere Dateien)
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellEntfernenTasteui_click (entfernt die markierten Dateien)
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellStandard – nur die mit DReS installierte Anleitung (template\RCS\AIAgent\rcs_agent_instructions.md)Tasteui_click
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum ModellWissen neu laden – speichert die Liste und lädt die Dateien neu in das Fenster des KI-Agenten; die Unterhaltung bleibtTasteui_click; ai_chat message "/reload" (ohne die Liste zu speichern)
KI-Agent > Fenster des KI-Agenten (Registerkarte neben den Meldungen) - Verbindung zum Modell(Zusammenfassung unter der Liste) n Datei(en), x Zeichen (etwa y Tokens); nicht gefundene DateienTextui_get (Text)
KI-AgentDokumentation – Einrichtung des KI-Agenten Schritt für Schritt, öffnet sich im Browser (linke untere Ecke der Registerkarte)Tasteui_click
SimulationAusgang 'Prozess aktiv' (PrAct):Textfeldui_set "Text"
SimulationIm Hintergrund vorbereitete Makros:Textfeldui_set "Text"
SimulationKollisionsmerker in Makros suchen:Textfeldui_set "Text"
SimulationSuchlauf: Strecke mit Vred: (0 … 10000)Zahlui_set Zahl
SimulationSuchlauf: längste Zeit: (0 … 3600)Zahlui_set Zahl
SimulationFB PSPS während der Bewegung prüfen: (0 … 10000)Zahlui_set Zahl
SimulationKein Halt auf der Prozessbahn (LIN, CIRC, KLIN, KCIR, KPTP, SLIN, SCIR, Spline)Kontrollkästchenui_set true / false
SimulationWettlauf um einen Bereich - Zeitfenster: (0.1 … 5)Zahlui_set Zahl; race_rules window
SimulationFenster mit den Wettläufen am Ende einer StationssimulationKontrollkästchenui_set true / false; race_rules message
SimulationReihenfolge der Roboter bei einem Wettlauf während des Laufs beibehalten [ein] – das SPS-Programm wird nicht geändertKontrollkästchenui_set true / false; race_rules lock; Schlüssel Race_Lock_Order
SimulationGespeicherten Bericht (HTML, PDF) im Standardprogramm öffnen [ein] – Zeitenbericht, Bericht des Robustheitstests, Bericht der KollisionsrisikenKontrollkästchenui_set true / false; eigener Befehl report_open (open true / false; ohne open: lesen)
SimulationModellkonverter (JT nach glTF): – Pfad von modelconv.exe (GNU GPL v3; leer = automatisch <Programmordner>\RuntimeTools\modelconv\modelconv.exe), Ordner-Schaltfläche, Standard (leert das Feld), Zustand gefunden / nicht gefunden (siehe Plugin-Einstellungen > Simulation)Textfeld + Schaltflächenui_set "Text" (gespeichert mit OK); eigener Befehl model_converter (path "..." / "" = automatisch; ohne path: lesen; Antwort path, default, found); Schlüssel Model_Converter
SimulationJT-Modelle: umgewandelte glTF-Modelle verwenden: – Auto - fehlende Modelle ohne Rückfrage umwandeln (Standard), Fragen - ein Fenster vor dem Umwandeln, Nie - JT-Dateien direkt laden (siehe JT-Modelle als glTF)Listeui_set Index / Text (gespeichert mit OK); eigener Befehl model_cache (convert "auto" | "ask" | "never"); Schlüssel JT_Convert_Mode
SimulationUmgewandelte Modelle speichern: – Neben der JT-Datei (Standard) / Gemeinsamer Ordner: + Ordnerfeld (leer = %LOCALAPPDATA%\DrAmaT\RCS\Models) + Ordner-SchaltflächeOptionsfelder + Textfeldui_set (gespeichert mit OK); model_cache (mode "nextToJt" | "folder", folder); Schlüssel JT_Convert_Location, JT_Convert_Folder; Schätzung einer Datei: model_cache estimate + file (estimateAll für eine Studie, unreadable; secondsPerFile / secondsPerMB / parallel aus den Schlüsseln JT_Convert_JobSecPerFile, JT_Convert_JobSecPerMB, gelernt aus den letzten Umwandlungen, seit 2026-10-25)
Available objects (Öffnen einer Studie)Bereich JT-Modelle als glTF: JT-Modelle in glTF umwandeln und die umgewandelten Modelle laden, Anzahl der umzuwandelnden Modelle der gewählten Komponenten / MB / geschätzte Zeit, Umgewandelte Modelle speichern (wie in den Einstellungen)Kontrollkästchen, Text, Optionsfelder, Textfeldui_set bei offenem Fenster; API open (convert) nimmt ohne Fenster die Einstellung; Auswahl der Objekte: API open objects "all" (= Select all) oder eine Auswahldatei .ini (= Schaltfläche Open des Fensters), seit 2026-10-25; in der Variante ohne JT-Leser zählt der Bereich auch die Roboter und die Mechanismen
JT-Modelle (Fenster des Modus Fragen)N JT-Modelle sind noch nicht umgewandelt (X MB). Geschätzte Zeit: etwa Y s., Umgewandelte Modelle speichern, Nicht mehr fragen (automatisch umwandeln), Schaltflächen Umwandeln und laden / Ohne sie laden; danach der Fortschrittsbalken JT-Modelle werden in glTF umgewandelt... mit AbbrechenFensterbei API-Befehlen nie angezeigt (convert "ask" wirkt wie "auto"); ui_click auf die Schaltflächen; status.converting / status.modelConversion
SimulationProzessorkerne für die Roboter: (0 … 5)Zahlui_set Zahl
KollisionsberichtBenachbarte Punkte derselben Stelle als ein Fall (z. B. UP48/P23-P25) [ein] – Fenster der Kollisionsgefahren und Berichte (siehe Plugin-Einstellungen > Kollisionsbericht)Kontrollkästchenui_set true / false (ui_list mit window "Einstellungen"); gilt auch für collision_report
SignalbeschreibungenStandard-Langtexte des VW-Standards im SmartPad und im SignalfensterKontrollkästchenui_set true / false
SignalbeschreibungenLangtexte-Verzeichnis:Textfeldui_set "Text"
SignalbeschreibungenLangtexte-Verzeichnis wählen (KS Teil 4 > Langtexte)Tasteui_click
SignalbeschreibungenStandardTasteui_click
Signalbeschreibungen(ohne Beschriftung - über id / Pfad)Tabelleui_view / ui_view_set / ui_context
SignalbeschreibungenDateien wählen...Tasteui_click
SignalbeschreibungenStandard für die ZeileTasteui_click
SignalbeschreibungenAlles StandardTasteui_click


« Befehls-API | Inhalt | Ablauf, Prozessor und Genauigkeit »